
Modified multicore application as the proof-of-concept for local and remote visualization of GPR data via ESP32-S3 board with TFT SPI 240x320 display 

The modified multicore application is modification of the unified multicore application for ESP32 and RP2040 with 3.2” TFT SPI 240x320 display to run on RP2040, ESP32-WROOM and ESP32-S3-WROOM based boards. The 
main bug ( impossibility to display and edit SPIFFS files in the file browser in case of compiling application against Espressif ESP32 core 2.0 or later) is fixed by own code instead of using SPIFFSEditor library component (part of 
the core ESPAsyncWebServer library). SPIFFS structure is changed to separate private and public files. The development process was eased thanks to using USB OTG JTAG/Serial (USBSerial) and UART0 (Serial) interfaces for 
uploading the program and printing of debug messages respectively. Serial ports on UART1 (Serial1) and UART2 (Serial2) are used to connect GPR and GPS devices. 

It is also added a code to read GPR data via serial port and display them on local TFT display. A code based on AsyncEventSource is also added to send GPR data to all registered remote clients. Demo version of remote GPR data 
viewer is developed as web application to prove the concept. As it is visible from the photo below 5x remote clients are served in addition to the local display. There is no disturbance in any of the served local and remote viewers at 
more than 30 tps (tracks per second). For the moment GPR data are sourced by written in JavaScript simulator reading them from a SEGY file. At the first tests application can run on all Pi Pico W, ESP32-WROOM and ESP32-s3-
WROOM based boards but only on ESP32-s3-WROOM one it is working without problems and stable enough. 

In the final application for GPR data visualization some of the components in current application will be removed or modified and others will be added. The control of the GPR device by the local and remote viewers is under 
discussion. In case of remote control of the GPR device the concurrence may cause problems so it has to be assessed its usefulness. There are following alternatives for the local control: touch screen, rotational encoder or buttons. 
It is cleaner remote viewers to control visualization only. Saving of GPR data to file locally and/or remotely has to be discusses as well. 

Modified multicore application in pictures 

   
Test suit photo Main web page view with remote GPR data viewer  

    
SPIFFS browser Internal data monitor WiFi setup view TFT SPI display with GPR data 



Modified multicore application for ESP32-S3-WROOM-1, RP2040 & CYW43439 and ESP32-WROOM with 3.2” TFT SPI 240x320 display – summary in pictures 
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56 tps @ 460800 bps 
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16 tps @ 115200 bps 

 



Unified multicore application for ESP32, RP2040 with 3.2” TFT SPI 240x320 display – summary in pictures and projects history 

  

 

 

Projects history 

 First cycle of tests included unified graphics test running on Arduino UNO (ATMega328), 
Arduino Leonardo (ATMega32u4), Arduino D1 R32 / ESP32, Raspberry Pi Pico W (RP2040) 
and Self-made AVR128db48 boards connected to 3.2” TFT SPI 240x320 display. Application 
is based on Adafruit performance tests for Adaruit_ILI9341 / Adafruit_GFX and adapted for 
TFT_ ILI9341 and TFT_eSPI libraries. Meanwhile Olimex ESP32-S2 (WROOM and 
WROVER) boards were tested with multitasking “Hello world & RGB LED”. Another test 
done is based on ESP32-CAM module as a base of own implementation of Wifi Camera Robot 
Car project. As a result following open source projects are posted on GitHub: 

 Unified-ILI9341-Graphic-Test 

 Unified-ILI9341-Graphic-Test-plus 

 Next cycle of tests was performance assessment of networking capabilities of WiFi equipped 
ESP32 and Pi Pico W boards. Test applications are based on Arduino libraries 
ESPAsyncWebServer and AsyncWebServer_RP2040W. Special attention was paid to 
asynchronous web services, web sockets, WiFi management and unification possibility for both 
ESP32 and Pi Pico W platforms. 

 Next step done was to adapt DrawWithDMA sketch created by Bodmer as example for 
TFT_eSPI library to work on ESP-WROOM-32 and RP2040 boards. Modified sketch is 
posted on GitHub as open source: 

 DrawWithDMA 

 Next cycle of tests was directed to multicore task execution on dual core versions of ESP32 
and RP2040 based boards. United version of AsyncFSBrowser demo with Unified graphic test 
(TFT-eSPI library case) and modified DrawWithDMA sketch was implemented as multi-file 
Arduino IDE project running on both Arduino D1 R32 ESP32 (ESP32-WROOM) and 
Raspberry Pi Pico W (RP2040) boards. It includes web server with web sockets service, TCP 
server for network performance assessment, internal SPI Flash FS file viewer and editor, 
monitor showing graphs of the free heap memory, the GPIO states, the internal temperature 
and the animation frame rate. It also includes accounts management of WiFi in AP and/or 
STA modes. Graphics part of the application is implemented as tasks alternatively running on 
second CPU core. Control is based on web sockets and includes built-in LED, running of 
network tasks like ping, time, iperf and switching of graphic tasks (Adafruit tests and 
DrawWithDMA animation). Results of network commands and Adafruit tests are printed on 
monitoring web page. Unified multicore application will be posted on GitHub as soon as 
become more stable. 

 Next cycle of tests started is modification of Unified multicore application for working on 
ESP32-S3-R8N8 (Olimex ESP32-S3-DevKit-Lipo) to display locally and remotely GPR 
(Ground Penetrating Radar) data currently generated by simulator. First test done shows that 
displaying data locally on 3.2” TFT SPI 240x320 display is stable at speeds 60+ tracks per 
second (at 460800 bps over serial) while all network services work on the second CPU core. 

 Next cycle of tests started is experimenting with Pi Pico PIO engine functionality. It was used 
Raspberry Pi Pico, Olimex RP2040-PICO-PC boards and 5” TFT HDMI 800x480 display and 
as a beginning adapted by Adafruit Arduino IDE version of PicoDVI library and example tests 
were running successfully. 

All the time the performance table (next page) was updated with the benchmark results measured 
by Adafruit graphics and DrawWithDMA tests. The connection table (page 5) was also updated. 

 

 

 
  

    

    

Full color PicoDVI test on Raspberry Pi Pico, RP2040-PICO-PC and 5” TFT HDMI 800x480 display 

          
 

https://github.com/adafruit/Adafruit_ILI9341
https://github.com/adafruit/Adafruit-GFX-Library
https://github.com/Bodmer/TFT_ILI9341
https://github.com/Bodmer/TFT_eSPI/issues/1460
https://dronebotworkshop.com/esp32cam-robot-car/
https://dronebotworkshop.com/esp32cam-robot-car/
https://github.com/chradev/Unified-ILI9341-Graphic-Test
https://github.com/chradev/Unified_ili9340_Graphic_Test_plus
https://github.com/me-no-dev/ESPAsyncWebServer
https://github.com/khoih-prog/AsyncWebServer_RP2040W
https://github.com/Bodmer/TFT_eSPI/tree/master/examples/DMA%20test/Bouncy_Circles
https://github.com/chradev/DrawWithDMA
https://github.com/me-no-dev/ESPAsyncWebServer
https://github.com/adafruit/PicoDVI


Benchmark of unified graphic and scroll tests built on Adafruit_ILI9341, TFT_ILI9341 and TFT_eSPI libraries 

Arduino board / MCU UNO / ATMega328 Leonardo / ATMega32u4 D1 R32 / ESP32 Pi Pico / RP2040 Pi Pico / RP2040 (Overclocked) Unified App AVR128db48 ESP32-S3 

ILI9341 Library used 
(SPI clock) 

Adafruit TFT 
Spee
d up 

Adafruit TFT 
Spee
d up 

Adafruit 
(3MHz) 

TFT_eSPI 
Speed 

up 
Adafruit 

TFT_eSPI 
(27MHz) 

Speed 
up 

Adafruit 
TFT_eSPI 
(62.5MHz) 

Speed 
up 

TFT_eSPI  
with DMA 

Adafruit 
Adafruit 
(27MHz) 

Memory usage [B]                   

Flash used: 

23,736 of  
32,256  

(73.59%) 

21,870 of 
32,256 

(67.80%)  

25,874 of 
28,672 

(90.24%) 

23,992 of 
28,672 

(83.68%)  

237,600 of 
1,310,720 
(18.13%) 

295,261 of 
1,310,720 
(22.52%)  

327,772 of 
2,093,056 
(15.65%) 

372,092 of  
2,093,056  
(17.78%)  

327,868 of 
1,568,768 

(20%) 

372,180 of 
1,568,768  

(23%)  

505,232 of 
1,044,480 

(48%) 

24,354 of 
130,560 

(18.65%) 

295,261 of 
1,310,720 
(22.52%) 

SRAM used: 

950 of  
2,048  

(46.39%) 

746 of 
2,048 

(36.43%)  

915 of  
2,560  

(35.74%) 

711 of 
2,560 

(27.77%)  

37,264 of 
327,680 

(11.37%) 

19,480 of 
327,680 
(5.94%)  

71,324 of 
262,144 

(27.21%) 

71,768 of  
262,144  

(27.38%)  

71,324 of  
262,144  

(27%) 

71,768 of  
262,144  

(27%)  

74,912 of  
262,144 

(28%) 

1,087 of  
16,384  

(6.63%) 

19,480 of 
327,680 
(5.94%) 

Benchmarks [us]        ~42°C   ~32°C   ~34°C  ~36°C  ~50°C 

Screen fill 1,496,456 870,220 1.720 1,503,900 874,600 1.720 2,120,993 274,575 9.097 604,056 281,577 2.145 497,451 107,972 4.607 107,567 1,603,604 274,575 

Text 147,088 60,416 2.435 147,820 60,724 2.434 99,610 32,599 6.491 45,452 18,831 2.414 30,599 8,085 3.785 8,070 114,885 32,599 

Lines 1,172,116 242,732 4.829 1,178,004 243,988 4.828 986,748 339,491 10.975 454,856 101,897 4.464 304,234 42,741 7.118 43,648 946,199 339,491 

Horiz/Vert Lines 125,064 71,336 1.753 125,656 71,696 1.753 173,171 24,171 8.603 50,042 23,541 2.126 40,853 9,078 4.500 8,880 132,637 24,171 

Rectangles (outline) 82,228 45,844 1.794 82,632 46,076 1.793 110,682 15,996 8.697 32,657 14,932 2.187 26,417 5,773 4.576 5,686 85,703 15,996 

Rectangles (filled) 3,107,060 1,807,436 1.719 3,122,844 1,816,740 1.719 4,402,687 570,510 9.096 1,253,856 584,372 2.146 1,032,576 224,086 4.608 223,506 3,329,307 570,510 

Circles (filled) 452,728 284,064 1.594 454,916 285,536 1.593 492,735 95,809 7.704 167,914 71,149 2.360 126,969 28,025 4.531 27,896 423,221 95,809 

Circles (outline) 497,252 135,580 3.668 499,604 136,148 3.670 432,728 150,143 12.978 199,626 37,258 5.358 133,263 15,561 8.564 15,743 404,412 150,143 

Triangles (outline) 261,056 59,496 4.388 262,392 59,808 4.387 225,959 74,819 10.265 101,400 23,636 4.290 68,473 10,319 6.636 10,463 213,681 74,819 

Triangles (filled) 1,330,720 694,456 1.916 1,337,200 698,032 1.916 1,432,757 209,558 8.691 429,998 195,995 2.194 345,244 75,450 4.576 75,102 1,279,412 209,558 

Rounded rects (outline) 228,892 100,004 2.289 230,024 100,532 2.288 230,767 62,675 11.013 92,280 23,635 3.904 65,233 9,576 6.812 9,602 200,582 62,675 

Rounded rects (filled) 3,127,968 1,976,936 1.582 3,143,588 1,987,180 1.582 4,384,111 578,880 8.995 1,257,871 586,292 2.145 1,032,024 225,027 4.586 224,252 3,330,751 578,880 

Fill screen by pixels 3,369,992 918,732 3.668 3,387,308 923,492 3.668 2,783,609 1,591,181 3.331 1,255,234 504,753 2.487 805,373 229,258 3.513 159,327 2,964,859 1,591,181 

Fill screen by bitmaps 528,576 855,088 0.618 531,112 859,520 0.618 435,203 62,752 0.518 66,438 520,180 0.128 70,363 234,904 0.300 166,092 453,099 62,752 

Scroll and fill screen 532,988 855,696 0.623 535,808 860,132 0.623 439,860 67,668 0.520 69,357 521,011 0.133 71,933 235,385 0.306 166,606 457,946 67,668 

Min 82,228 45,844  82,632 46,076  99,610 15,996  32,657 14,932  26,417 5,773  5,686 85,703 15,996 

Avg 1,097,346 598,536 1.833 1,102,854 601,614 1.833 1,250,108 276,722 4.497 405,402 233,937 1.733 310,067 97,416 3.183 83,496 1,062,687 276,722 

Max 3,369,992 1,976,936  3,387,308 1,987,180  4,402,687 1,591,181  1,257,871 586,292  1,032,576 235,385  224,252 3,330,751 1,591,181 

Sum 16,460,184 8,978,036  16,542,808 9,024,204  18,751,620 4,150,827  6,081,037 3,509,059  4,651,005 1,461,240  1,252,440 15,940,298 4,150,827 

DrawWithDMA test 
(bounsing of 42 colored 
and numbered circles) 

       
36fps 

(Unified 
App) 

  
17.8 fps at 

CPU 133MHz  
SPI 27MHz 

  
46.5 fps at 

CPU 250MHz  
SPI 62.5MHz 

2.6 
46.5 fps at 

CPU 250MHz  
SPI 62.5MHz 

 
60+ tps at 
GPR data 

visualisation 

Notes: 

 Memory usage numbers are as reported in runtime and slightly different than one reported by the compiler; 

 Preparing of the data for filling the screen by pixels or bitmaps are made to be as fast as possible; 

 Numbers for “Scroll and fill screen” tests at TFT_ILI9341 and TFT_eSPI libraries should be revised; 

 At combination ESP32 and Adafruit_ILI9341 library SPI frequency was lowered to 3MHz while in case of 
ESP32 S3 SPI frequency can be increased up to 27MHz but in unified application with WiFi networking 
TFT_eSPI library has some problems especially at using DMA; 

 Numbers in “Speed up” column means the operation is that many times faster; 

 Overclocking in case of Pi Pico includes increasing of SPI and CPU speeds up to 62.5MHz and 250MHz 
respectively and application of suggested solution by Bodemar in his Github issue 1460 (working reliably 
even with 30cm long wires); 

 Cases with ESP32 (Unified App), overclocked RP2040 (Unified App) and ESP32-S3 (colored in light 
violet) were measured by Unified multicore application (in combination with AsyncFSWebBrowser). 

Useful links for display of animation with DMA and speed assessment: 
Raspberry Pi Pico with ILI9341 TFT and TFT_eSPI Arduino library using RAM & DMA 
https://forum.arduino.cc/t/tft_espi-support-for-raspberry-pi-pico-added/702551 
https://www.youtube.com/watch?v=njFXIzCTQ_Q 
https://github.com/Bodmer/TFT_eSPI/issues/1460#issuecomment-1006661452 

This application uses two sprites in RAM and DMA for filling display half buffer while updating the other half. 
The ILI9341 display operates reliably on Pi Pico up to 62.5MHz so frame rate up to ~43fps is possible with 
DMA. Overclocking CPU to 250MHz and applying Bodmer note makes it possible frame rates to go up to 
46.5fps. The total consumption in overclocked mode of both Pi Pico and SPI TFT is 110mA. The application is 
unified to run on both RP2040 and ESP-WROOM-32 boards. In case of ESP32 frame rate was lower (~36fps). 

 

https://youtu.be/njFXIzCTQ_Q
https://forum.arduino.cc/t/tft_espi-support-for-raspberry-pi-pico-added/702551
https://www.youtube.com/watch?v=njFXIzCTQ_Q
https://github.com/Bodmer/TFT_eSPI/issues/1460#issuecomment-1006661452


Modified multicore application for ESP32-S3, RP2040 and ESP32 to display GPR data locally and remotely 

Modified multicore application is based on Unified multicore application which is combination of AsyncFSBrowser demo application, Unified graphic test 
(TFT-eSPI library) and DrawWithDMA sketches. It is targeted to ESP32-S3 based Olimex ESP32-S3-DevKit-Lipo board. 

ESP32-S3 is a dual-core XTensa LX7 MCU, capable of running at 240 MHz. Apart from its 512 KB of internal SRAM, it also comes with integrated 2.4 GHz, 
802.11 b/g/n Wi-Fi and Bluetooth 5 (LE) connectivity that provides long-range support. It has 45 programmable GPIOs and supports a rich set of peripherals. 
ESP32-S3 supports larger, high-speed octal SPI flash, and PSRAM with configurable data and instruction cache. 

Olimex ESP32-S3-DevKit-Lipo board with ESP32-S3-WROOM-1-N8R8 has 8MB PSRAM and 8MB SPI Flash. It also has pUEXT and 2x USB C connectors 
(via CH340 USB-serial adapter and native OTG JTAG/Serial with on-chip PHY), LiPo battery charger and connector, user and reset buttons and user and 
charge LEDs. All GPIO pins are routed to 2x22 pins connectors compatible to the Espressif ESP32-S3-DevJitC-1. 

Development is made on Windows 7 / 10 using Arduino IDE (ver. 1.8.9), the latest Espressif system version 2.0.14, AsyncWebServer, Adafruit_ILI9341, 
Adafruit_GFX etc. libraries (all latest versions). Node.JS (ver. 12.22.9) with serialport library (ver. 8.0.5) is used to develop and use “gpr-simulator” application. 

To power and connect the board to the computer may use powered 4+ USB Hub, 2x USB A to USB C cables and 2x CP2102 USB-to-Serial adapters. Install 
CH340 and CP210x drivers for Windows if required. 

   
 

  
For user configuration of internal SPI flash do following changes: 

In ESP32 boards file: C:\Users\BI\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.14\boards.txt 

add following lines to esp32s3.name=ESP32S3 Dev Module section: 

esp32s3.menu.PartitionScheme.users_8MB=8M with spiffs (2MB APP/2MB OTA/4MB SPIFFS) 

esp32s3.menu.PartitionScheme.users_8MB.build.partitions=users_8MB 

esp32s3.menu.PartitionScheme.users_8MB.upload.maximum_size=2097152 

Add: C:\Users\BI\AppData\Local\Arduino15\packages\esp32\hardware\esp32\2.0.14\tools\partitions\users_8MB.csv 

with following content: 

# Name,   Type, SubType, Offset,  Size, Flags 

nvs,      data, nvs,     0x9000,  0x5000, 

otadata,  data, ota,     0xe000,  0x2000, 

app0,     app,  ota_0,   0x10000, 0x200000, 

app1,     app,  ota_1,   0x210000,0x200000, 

spiffs,   data, spiffs,  0x410000,0x3e0000, 

coredump, data, coredump,0x7F0000,0x10000, 

Restart Arwuino IDE changes to take effect  

Save new copy of Unified multicore application under other name (like GPR_Display) and remove not relevant components like TCPServer.ino, 
DrawWithDMA.ino, Unified_ili9340_Graphic_Test_plus.ino and create new components GPR_Task.ino and GPS_Task.ino. Additional component SPIFFS 
based FSEditor.ino is added instead of SPIFFSEditor to overcome its problem if ESP32 core ver. 2.0 and later is used. Restructure SPIFFS file staff to separate 
private and public files. Restart Arduino IDE and re-flash SPIFFS changes to take effect. Modify the staff in GPR_Display.ino and WebSockets.ino according to 
changes made. Write required staff in GPR_Task.ino to read data from Serial2 and display them on 3.2” TFT SPI 240x320 display. GPR_Task has to be set to 
run on CPU core0 (not running main application). Use board configuration in Arduino -> Tools as shown above. ESP32-S3 may be programmed via native 
USB OTG JTAG/Serial port (COM23). Serial0 port via CH230 USB-to-Serial adapter (COM20) is used for debug information printing and as a spare channel 
for application programming. ESP32-S3 Serial2 port is used to connect GPR and Serial1 port is reserved to connect GPS module later on. 

Web files are located in project subfolder named “data”. They can be flashed to internal flash SPIFFS using Arduino tool “ESP32 Sketch Data Upload”. 
Application “esp_tools_gui” may also be used to check ESP32-S3 information and configuration. For testing purposes JavaScript simulator is written to read 
GPR data from SEGY file and send them to ESP32-S3 Serial2 port (via CP2102 USB-to-Serial adapter on COM22). In future is planed JavaScript GPS 
simulator to be developed to read GPS data from file and send them to ESP32-S3 Serial1 port (via CP2102 USB-to-Serial adapter on COM21). 

Notes: 

 In future both USB OTG JTAG/Serial and CH230 USB to Serial0 ports may be used as USB Mass storage host (for storing of archive data files) and CDC 
device (for connecting to other computer) respectively but some issues have to be solved so currently they will be used for development purposes only; 

 In case of more space needed SPIFFS partition scheme can be changed or ESP32-S3 module with more flash (16/32MB) can be used; 

 Usage of SPI SD card slot located at 3.2” TFT SPI 240x320 display board for storing of archive files is also possible; 

 Lack of ESP32-S3 reset after application flashing via USB OTG JTAG/Serial port bug is not observed; 



Unified multicore application for ESP32 and RP2040 – more than combination of AsyncFSWebBrowser and graphic tests 

 

 

 

Unified multicore application is based on AsyncFSBrowser, Unified graphic test (TFT-eSPI library) and DrawWithDMA sketches. It is Arduino IDE multi-file 
project for ESP32-WROOM and RP2040 based boards. It is running on both Arduino D1 R32 ESP32 (ESP32-WROOM) and Raspberry Pi Pco W (RP2040) 
boards and implements web server and sockets, console with printout of the Adafruit TFT tests adapted for eTFT library and log of swapping graphical tasks to 
work on the other core, web application with internal monitor showing graphs of the free heap memory, the GPIO states, the internal temperature sensor and 
the animation frame rate. On the right are shown pictures of graphical tasks (animation and graphical tests) running alternatively on the other core. 

The most attractive application feature is almost complete independency of the performance of tasks running on different CPU cores. Other impressive result is 
graphical performance of animation task (46 frames per second at 42 bouncing circles) and all Adafruit TFT tests adapted to work with the eTFT library 
(especially scrolling 320x240 graphics at speed of 0.8ms per 240 pixels line). Next pictures represent final version of unified multicore application in action. 

 

Home view of the web application with control staff and system information (left) and control staff with internal FS file viewer and editor (right) 

 

 

 

On the left most pictures are shown views with graphs of the internal system and application parameters (left) and WiFi setup page (right). It is evident that the 
results of the invoked commands and monitor (as well as other clients) are synchronized and ESP32 WiFi works in AP+STA mode (top left WiFi status). 
Graphical task log in the monitor view is showing the best results ever achieved (look at the table on page 7). This snapshot is taken after complete unification of 
the application for Pi Pico W (left) and ESP32 (right) platforms and adding network tasks control bar (only ping is implemented for the moment). 

On the right most pictures are shown TFT displays in action connected to Pi Pico (top left) and ESP32 (top right) boards while running unified application. The 
current state of the application is not stable and has some bugs especially for ESP32 where bouncing circles are only moving at the bottom half of the screen, 
Adafruit tests do not work as expected and the application crashes frequently at exchanging of the graphic tasks. In case of Pi Pico applications is more stable 
but crashes form time to time at exchanging of the graphic tasks. 

In the special modification of the unified multicore application running on ESP32-S3-R8N8 (right most bottom) is implemented preliminary test for displaying 
of data from GPR (Ground Penetration Radar) received via serial link and shown as 320x240 pixels scrolling graphics with up to 18 tracks per second speed. 



Network performance using AsyncWebServer and AsyncTCP libraries on Pi Pico W and ESP32 series of boards 

Startup projects working on ESP32 S2 Olimex boards and based on 
ESPAsyncWebServer library for Arduino: 

  
 ESP32: Create a Wi-Fi Manager (AsyncWebServer library) 

Application uses SPIFS on ESP32 systems to hold web and configuration files 
which have to be written manually by “ESP32 Sketch Data Upload” tool of 
Arduino IDE. The application first runs in AP mode asking for connection 
credentials of the local router. After storing them in FS files and restart it runs 
in STA mode. Main web page allows controlling built-in LED. 

  
 ESP32 WebSocket Server: Control Outputs (Arduino IDE) 

  
Application on ESP32 runs in STA mode with credentials defined in the 
sketch and open WebSocket server to control the LED. Its status can be 
changed by any client and will be updated at all the clients. 

It was used Adafruit NeoPixel library to run above projects on Olimex ESP32 
S2 series of boards with RGB instead of regular LED. 

Startup projects on Raspberry Pi Pico W – AsyncWebServer for RP2040W 
library examples: 

 

 

 

 Async_AdvancedWebServer 

 

  

 

 AsyncFSWebServer (library ver. 1.5.0 did not run out of the box) 

Application uses LittleFS library to access SPI flash FS. It also uses mDNS, 
basic authentication, AsyncWebSocket, AsyncEventSource and 
AsyncFSEditor_RP2040W library to show and edit files. 

DrawWithDMA TFT_eSPI library test was compiled and run successfully on Raspberry Pi Pico W. Later on AsyncFSWebServer and DrawWithDMA combined 
multicore application was done by simply putting both files in a single project, renaming setup and loop functions in the second file to setup1 and loop1 and 
commenting the line Serial.begin(115200). Display drawing (42 circles) speed was the same (17.85fps) without appreciable change in the web access. 
Temperature measured by internal sensor is increased with approximately 2°C (up to 31°C). The heap is increased from 5kB up to 159kB. CPU overclocking to 
250MHz did not speed up display drawing and web access but increase the temperature with approximately 3°C (up to 34°C). SPI speed can be changed in 
User_Setup.h of TFT_eSPI library. Changing it from 27MHz to 55MHz (2x) did not speed up display drawing but thanks to Bodmer comment and CPU 
clocking at 125MHz (SPI clock is 62.5MHz) display drawing can be speed up to 43-45fps @42 circles and 46.3fps @36 circles. Overclocking CPU to 250MHz 
(probably SPI clock is again 62.5MHz) increase display drawing speed up to 46.5fps @42 circles (2.6x) while working smoothly and reliably. Total consumption 
is increased form 110mA in case of overclocked DrawWithDMA single core application up to 144mA for combined multicore application. 

 +  +  
Remote file manager and editor On-line monitor SPI TFT display 

AsyncWebServer for RP2040W library built by Khoi Hoang is based on and modified from ESPAsyncWebServer library support of ESP32 and ESP8266 on 
Arduino cores. Next steps to be done for building of unified multicore application: 

 Check of the code compatibility for both ESP32 and Pi Pico W boards; 

 Dynamically running of different tasks on the second CPU core; 

 Build unified web server application with WiFi working in AP and/or STA modes including its management, mDNS, LittleFS, WebSockets etc. 

https://github.com/me-no-dev/ESPAsyncWebServer
https://randomnerdtutorials.com/esp32-wi-fi-manager-asyncwebserver/
https://randomnerdtutorials.com/esp32-websocket-server-arduino/
https://github.com/khoih-prog/AsyncWebServer_RP2040W
https://github.com/khoih-prog/AsyncWebServer_RP2040W
https://github.com/Bodmer/TFT_eSPI/issues/1460#issuecomment-1006661452
https://github.com/khoih-prog/AsyncWebServer_RP2040W
https://github.com/me-no-dev/ESPAsyncWebServer


Connection setup for 3.2” 240x320 pixels TFT display with SPI interface 

 
3.2” TFT SPI 
LCD Display 

Arduino UNO 
ATMega328 

Olimexino32U4 
ATMega32u4 

Optiboot 
AVR128db48 

Arduino R32 
ESP-WROOM-32 

Raspberry PI  
Pico RP2040 

ESP32-S3-
WROOM 

Signal description  
(3.2” TFT SPI LCD Display) 

1 VCC VCC-3.3V VCC-3.3V VCC-3.3V VCC-3.3V VCC-3.3V 3.3V 3.3V power input (do not connect to 5V) 

2 GND GND GND GND GND GND GND GND 

3 CS D10 D13 0,#SS, PA7 IO05 GP17 GPIO10 LCD chip select signal, low level enable 

4 RESET D8 D4 PA2 (0,SDA) IO12 GP21 GPIO9 LCD reset signal, low level reset 

5 DC/RS D9 D11 PA3 (0,SCL) IO13 GP20 GPIO14 
LCD register / data selection signal, high level: 

register, low level: data 

6 SDI(MOSI) D11 D16 0,MOSI, PA4 IO23 GP16 GPIO11 SPI bus write data signal 

7 SCK D13 D15 0,SCK, PA6 IO18 GP18 GPIO12 SPI bus clock signal 

8 LED VCC-5V VCC-5V VCC-5V VCC-5V VCC-5V 5V 
Backlight control, high level lighting, if not 
controlled, connect 5V for always bright 

9 SDO(MISO) D12 D14 0,MISO, PA5 IO19 GP19 GPIO13 
SPI bus read data signal, if you do not need to 

the read function, you cannot connect it 

All 4 boards are connected to 3.2”SPI TFT display and running Unified graphic test 

 

 

 
Arduino UNO (ATMega328) Olimexino-32U4 (ATMega32u4) Arduino D1 R32 (ESP32) Optiboot (AVR128db48) 



Arduino Pi Pico (W) boards 

 For using Pi Pico (W) boards 

  

 In Preferences add URL: 

https://github.com/earlephilhower/arduino-

pico/releases/download/global/package_rp2040_index.json 

 

 Install Pi Pico / RP2040 in board manager 

 

 Install "Raspberry Pi Pico" or "Raspberry Pi Pico W" 

board 

 

 Connect the board to Windows PC while BOOTSEL button 

is pushed – “RPI-RP2” mass storage device should be 

appeared 

 After uploading the sketch “Pico” or “Pico W” device 

will be appeared in “Device Manager” 

 Update its device driver using Atmel USB to serial INF 

file changing [DeviceList.*] sections to: 

%PI_CDC_PICO%=DriverInstall, USB\VID_2E8A&PID_000A&REV_0100 or 

%PI_CDC_PICO%=DriverInstall, USB\VID_2E8A&PID_F00A&REV_0100 

 Change [Strings] sections also to appropriate once 

Multicore version of “Hello World and 

Blinking LED” common test for Pi Pico 

 Open from File -> Examples -> (Examples for Paspberry 

Pi Pico) -> FreeRTOS -> Milticore FreeRTOS sketch and 

safe it in your Arduino sketch folder: 

#include <FreeRTOS.h> 

#include <task.h> 

#include <map> 

#include <EEPROM.h> 

std::map<eTaskState, const char *> eTaskStateName { 

{eReady, "Ready"}, { eRunning, "Running" }, {eBlocked, 

"Blocked"}, {eSuspended, "Suspended"}, {eDeleted, 

"Deleted"} }; 

void ps() { 

  int tasks = uxTaskGetNumberOfTasks(); 

  TaskStatus_t *pxTaskStatusArray = new 

TaskStatus_t[tasks]; 

  unsigned long runtime; 

  tasks = uxTaskGetSystemState( pxTaskStatusArray, tasks, 

&runtime ); 

  Serial.printf("# Tasks: %d\r\n", tasks); 

  Serial.println("ID, NAME, STATE, PRIO, CYCLES"); 

  for (int i=0; i < tasks; i++) { 

    Serial.printf("%d: %-16s %-10s %d %lu\r\n", i, 

pxTaskStatusArray[i].pcTaskName, 

eTaskStateName[pxTaskStatusArray[i].eCurrentState], 

(int)pxTaskStatusArray[i].uxCurrentPriority, 

pxTaskStatusArray[i].ulRunTimeCounter); 

  } 

  delete[] pxTaskStatusArray; 

} 

void blink(void *param) { 

  (void) param; 

  pinMode(LED_BUILTIN, OUTPUT); 

  while (true) { 

    digitalWrite(LED_BUILTIN, LOW); 

    delay(750); 

    digitalWrite(LED_BUILTIN, HIGH); 

    delay(250); 

  } 

} 

void setup() { 

  Serial.begin(115200); 

  xTaskCreate(blink, "BLINK", 128, nullptr, 1, nullptr); 

  delay(5000); 

} 

volatile int val= 0; 

void loop() { 

  Serial.printf("C0: Blue leader standing by...\r\n"); 

  ps(); 

  Serial.printf("val: %d\r\n", val); 

  delay(1000); 

} 

// Running on core1 

void setup1() { 

  delay(5000); 

  Serial.printf("C1: Red leader standing by...\r\n"); 

} 

void loop1() { 

  static int x = 0; 

  Serial.printf("C1: Stay on target...\r\n"); 

  val++; 

  if (++x < 10) { 

    EEPROM.begin(512); 

    EEPROM.write(0,x); 

    EEPROM.commit(); 

  } 

  delay(1000); 

} 

 It demonstrates a simple use of the setup1()/loop1() 

functions for a multiprocessor run and following will 

be printed on the serial port while LED is blinking: 

C1: Stay on target... 

C0: Blue leader standing by... 

# Tasks: 9 

ID, NAME, STATE, PRIO, CYCLES 

0: CORE0            Running    4 191473164 

1: IDLE1            Running    0 3622023404 

2: IDLE0            Ready      0 3371562651 

3: BLINK            Blocked    1 5381238 

4: CORE1            Blocked    4 103437988 

5: USB              Blocked    6 3826967365 

6: Tmr Svc          Blocked    2 21071 

7: IdleCore1        Suspended  7 17213 

8: IdleCore0        Suspended  7 88986822 

val: 683 



ESP32-CAM 

 Getting Started With ESP32-CAM 

 All examples work with ESP32 Espressif 
System 2.0.9 

 

 Using ESP32-CAM-MB module makes programming easy 

  

Wifi Camera Robot Car 

 DIY ESP32 Camera Motor Shield - Wifi Camera Robot Car 

https://www.olimex.com/Products/IoT/ESP32/ESP32-CAM/ 

https://www.instructables.com/DIY-ESP32-Camera-Motor-Shield-

Wifi-Camera-Robot-Ca/, 

https://dronebotworkshop.com/esp32-cam-intro/ 

https://randomnerdtutorials.com/esp32-cam-video-streaming-web-

server-camera-home-assistant/ 

https://dronebotworkshop.com/esp32cam-robot-car/ 

 In “Resources” of the last link download: Code for ESP32CAM 
Car, the code needed to make this car work, all in one ZIP file. 

 To compile it use ESP32 Espressif System 1.0.6 

 

 Follow instructions in about the hardware : 
https://dronebotworkshop.com/esp32cam-robot-car/ 

 Main electrical parts 

 
Camera and motor driver interconnection Motor and ESP32-CAM module power 

 

 Power schematics 

 

 Final results 

 

Wifi Camera Robot Car – own implementation 

 
 

https://lastminuteengineers.com/getting-started-with-esp32-cam/
https://www.olimex.com/Products/IoT/ESP32/ESP32-CAM/
https://www.instructables.com/DIY-ESP32-Camera-Motor-Shield-Wifi-Camera-Robot-Ca/
https://www.instructables.com/DIY-ESP32-Camera-Motor-Shield-Wifi-Camera-Robot-Ca/
https://dronebotworkshop.com/esp32-cam-intro/
https://randomnerdtutorials.com/esp32-cam-video-streaming-web-server-camera-home-assistant/
https://randomnerdtutorials.com/esp32-cam-video-streaming-web-server-camera-home-assistant/
https://dronebotworkshop.com/esp32cam-robot-car/
https://s3.amazonaws.com/download.dronebotworkshop.com/ESP32CAM+Robot+Car+-+DroneBot+Workshop.zip
https://s3.amazonaws.com/download.dronebotworkshop.com/ESP32CAM+Robot+Car+-+DroneBot+Workshop.zip
https://dronebotworkshop.com/esp32cam-robot-car/


ESP32-S2/3 boards on Arduino IDE 

 For using ESP32-S2 boards like: 

   

ESP32-S2-DevKit-

Lipo 

ESP32-S2-WROVER-

DevKit-Lipo-USB 

ESP32-S3-DevKit-

Lipo 

 Install the ESP32-S2 support for Arduino IDE 

 In “File” → “Preferences” add URL: 

https://espressif.github.io/arduino-

esp32/package_esp32_index.json 

 In “Tools” → “Boards” → “Board Manager” search 

for the esp32 platform and install ver. 2.0.0 or later 

 

 Restart IDE and select board in “Tools” → “Board: 

o  “ESP32S2 Dev Module” for ESP32-S2-DevKit-Lipo 

 

o “ESP32S2 Native USB” for ESP32-S2-WROVER-DevKit-

Lipo-USB 

 

o “ESP32S3 Dev Module” for ESP32-S3-DevKit-Lipo 

 

 Connect ESP32-S2/3-DevKit-Lipo and install driver for 

USB-Serial CH340 adapter if needed 

 Connect ESP32-S2-WROVER-DevKit-Lipo-USB and put it in 

boot loader’s mode (hold GPIO0 low while reset) 

 Install driver with Zadig software if needed 

o Enable in “Options” → “List all devices” 

o Choose device“ESP32-S2 (Interface 2)” 

o And option “USB Serial (CDC)” 

 Any time for programming ESP32-S2-WROVER-DevKit-Lipo-

USB has to be put in boot loader’s mode and reset 

manually after uploading the sketch 

Multitasking “Hello World & RGB LED” test 

/* 

 * Requires Adafruit NeoPixel library 

 */ 

#include <Adafruit_NeoPixel.h> 

#define PIN 18 

#define NUMPIXELS 1 

#define PERIOD 10 //ms 

Adafruit_NeoPixel pixels(NUMPIXELS, PIN,  

NEO_GRB + NEO_KHZ800); 

int colors[3]; 

void setup() { 

  pixels.begin(); 

  for (int i = 0; i < 3; i++) colors[i] = 0; 

#if 1 

  Serial.begin(115200); // ESP32-S2-DevKit-Lipo 

#else 

  Serial.begin();// ESP32-S2-WROVER-DevKit-Lipo-USB 

  // Wait for serial port to connect. 

  // Needed for native USB port only. 

  while (!Serial) ; 

#endif 

  Serial.println("Hello World!"); 

  vTaskDelay(1000 / portTICK_PERIOD_MS); 

  xTaskCreate(loop2,"loop2", 2048, NULL,1,NULL); 

} 

int n = 0; 

void loop2( void * parameter ) { 

  while(1) { 

    Serial.print("Hello World - "); Serial.println(n++); 

    vTaskDelay(2000 / portTICK_PERIOD_MS); 

  } 

} 

void loop () { 

  for (int i = 0; i < 3; i++) { 

    int j; 

    for (j = 0; j < 256; j++) { 

      colors[i] = j; 

      pixels.setPixelColor(0, pixels.Color(colors[0], 

colors[1], colors[2])); 

      pixels.show(); delay (PERIOD); 

    } 

    for (j = 255; j >= 0; j--) { 

      colors[i] = j; 

      pixels.setPixelColor(0, pixels.Color(colors[0], 

colors[1], colors[2])); 

      pixels.show(); delay (PERIOD); 

    } 

  } 

} 

 Compiler messages for ESP32-S2-WROVER-DevKit-Lipo-USB 

Sketch uses 291526 bytes (22%) of program storage space. 

Maximum is 1310720 bytes. 

Global variables use 27596 bytes (8%) of dynamic memory, 

leaving 300084 bytes for local variables. Maximum is 

327680 bytes. 

 After running sketch on ESP32-S2-WROVER-DevKit-Lipo-

USB composite device will be installed with TinyUSB 

DFU_RT, CDC and ESP32-S2 Firmware MSC devices. 

 In terminal connected to USB-Serial CH340 following 

messages will be sent from ESP32-S2-DevKit-Lipo: 

ESP-ROM:esp32s2-rc4-20191025 

Build:Oct 25 2019 

rst:0x1 (POWERON),boot:0x8 (SPI_FAST_FLASH_BOOT) 

SPIWP:0xee 

mode:DIO, clock div:1 

load:0x3ffe6100,len:0x524 

load:0x4004c000,len:0xa70 

load:0x40050000,len:0x2958 

entry 0x4004c18c 

Hello World! 

Hello World – 0 

Hello World – 1 

 

System messages 

Sent from setup section 

Sent from loop2 task and will count every 2 sec 

https://zadig.akeo.ie/


Arduino D1 R32 ESP32 board 

 For using ESP32 boards like D1 R32 

 

 In Preferences add URL: 

https://dl.espressif.com/dl/package_esp32_index.json 

 

 Install esp32 in board manager 

 

 Connect the board to Windows PC 

 Install CH340 USB serial driver if needed and verify 

the port in “Device Manager”: COM6 for example 

 Install "ESP32 Dev Module" in board manager 

 

 Setup USB serial port as verified above 

 

Multitasking version of “Hello World & 

Blinking LED” test for ESP32 

 Create new project “HelloWorld” and put the sketch: 

void setup() { 

  Serial.begin(112500); 

  // By default the LED is connected to IO02 

  pinMode(2, OUTPUT); 

  // This will print default SPI pins 

  Serial.println("Default SPI pins:"); 

  Serial.print("MOSI: "); Serial.println(MOSI); 

  Serial.print("MISO: "); Serial.println(MISO); 

  Serial.print("SCK: ");  Serial.println(SCK); 

  Serial.print("SS: ");   Serial.println(SS); 

  vTaskDelay(1000 / portTICK_PERIOD_MS); 

  xTaskCreate(task1,"task1", 2048, NULL,1,NULL); 

  xTaskCreate(task2,"task2", 2048, NULL,1,NULL); 

} 

void loop() { 

  vTaskDelay(1000 / portTICK_PERIOD_MS); 

} 

void task1( void * parameter ) { 

  while(1) { 

    Serial.println("Hello World!"); 

    vTaskDelay(2000 / portTICK_PERIOD_MS); 

  } 

} 

void task2( void * parameter) { 

  while(1) { 

    digitalWrite(2, HIGH); 

    vTaskDelay(100 / portTICK_PERIOD_MS); 

    digitalWrite(2, LOW); 

    vTaskDelay(100 / portTICK_PERIOD_MS); 

  } 

} 

 After compilation will see: 

Sketch uses 204926 bytes (15%) of program storage space. 

Maximum is 1310720 bytes. 

Global variables use 13416 bytes (4%) of dynamic memory, 

leaving 314264 bytes for local variables. Maximum is 

327680 bytes. 

 After uploading sketch will see fast blinking LED and 

following messages in terminal to USB serial port: 

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT) 

configsip: 0, SPIWP:0xee 

clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x

00,wp_drv:0x00 

mode:DIO, clock div:1 

load:0x3fff0018,len:4 

load:0x3fff001c,len:1216 

ho 0 tail 12 room 4 

load:0x40078000,len:10944 

load:0x40080400,len:6388 

entry 0x400806b4 

Default SPI pins: 

MOSI: 23 

MISO: 19 

SCK: 18 

SS: 5 

Hello World! 

Hello World! 

 

Alternative ESP32 development boards from Olimex based  

on ESP32-WROOM-32 or ESP32-WROVER WiFi/BLE modules 

 

 
 

Variants compatible with Arduino D1 R32 ESP32 board: 

ESP32-DevKit-Lipo and ESP32-DevKit-Lipo-EA 

 

Default settings belongs to VSPI 

Will be repeated every 2 sec 



AVR128db48 Arduino boards 

 
Self-made AVR128db48 Arduino like board based on QFP adapter board 

Other boards notes: 

 Arduino UNO – install windows driver for USB-Serial CH340 adapter, 

 Olimexino Nano – install windows driver for Arduino Leonardo compatible boards, 

 Set in Tools → Board → Arduino AVR Boards → Arduino UNO or Arduino Leonardo respectively, 

 Set in Tools → Port → corresponding COM port, 

 LED pin may be different for different boards – change it in “Blinking LED” test sketch. 
 
 For using AVR128DB48 boards from Anton do: 

 Add URL in Preferences: 

http://drazzy.com/package_drazzy.com_index.json 

 Install DxCore ver. 1.3.2 in board manager 

 
 Connect CP2102 USB to UART Bridge to Windows PC 

 Install CP2102 USB driver if needed and verify the 

port: COM10 for example 

UPDI programmer (to burn bootloader) 

 Connect CP2102 USB to UART Bridge to the board 

o Rx ← 4.7k res. → Tx → AVR128DB48 UPDI (pin 41), 

o DTR → 200nF → RST (p. 40), GND, VCC (3.3V) 

 Programmer: "Serial Port + 4.7k Resistor (pyupdi 

style)" 

 Usage: Tools → Burn Bootloader 

 Usage: Sketch → Upload Using Programmer 

Regular serial programmer 

 Connect CP2102 USB to UART Bridge to the board 

o CP2102/TTL-232R Tx → AVR128DB48 Rx0 (p. 45) 

o CP2102/TTL-232R Rx ← AVR128DB48 Tx0 (p. 44) 

o DTR → 200nF → RST (p. 40), GND, VCC (3.3V) 

 Usage: Sketch → Upload 

 
Bootloader serial port could be USART2 (alt), but using 

USART0 the PC COM port for both programming and serial 

communication with the sketch will be the same. 

“Blinking LED” test for avr128db48 

void setup() { 

  // PIN_PC3 for avr128db48 

  // may be different for other boards! 

  pinMode(17, OUTPUT); 

} 

void loop() { 

  digitalWrite(17, 1); 

  delay(100); 

  digitalWrite(17, 0); 

  delay(100); 

} 


